SUPPORTED OS VERSIONS FOR THE SENSOR

SUPPORTED OS VERSIONS FOR THE SENSOR

Cybereason supports running sensors on Microsoft Windows, MacOS, Linux, and mobile devices.

With few exceptions, all features are supported across all supported operating systems. 

MICROSOFT WINDOWS

Operating system (PC) Operating system (Server)
Windows 10, up to Windows 10 20H2 (October 2020 Update) Windows Server 2019
Windows 8.1 Windows Server 2016
Windows 8 Windows Server 2012 R2
Windows 7 SP1 Windows Server 2012
Windows Server 2008 R2 SP1

KB REQUIREMENTS

OS Requires KB Notes
  • Windows Server 2012 R2
  • Windows 8.1
  • Windows Server 2012
  • Windows 8
  • Windows Server 2008 R2 Service Pack 1 (SP1)
  • Windows 7 SP1
KB2999226 This KB is also named Update for Universal C Runtime (CRT) in Windows and is required for the sensor to function.NOTE

For sensors using version 19.1.240 and later versions, you are not required to install KB2999226.

  • Windows 7 SP1
  • Windows Server 2008 R2 SP1
KB3033929 or KB4474419 Required to ensure support for SHA256 signatures. Note that other Microsoft patches may provide this functionality as well.

MACOS

Operating system
macOS Big Sur (11) - limited support1
macOS Catalina (10.15)2
macOS Mojave (10.14)
macOS High Sierra (10.13)
macOS Sierra (10.12)

1Sensors running macOS Big Sur do not currently support Anti-Malware > Signatures mode and collection of information about DNS requests.2Requires Nov. 12, 2019 Service Pack.

LINUX

Operating system
CentOS 6, 7, 8
Red Hat Enterprise Linux 6, 7, 8
Oracle Linux 6, 7
Ubuntu 14 LTS, 16 LTS, 18.04
SLES 121
Debian 8, 9
Amazon Linux AMI 2017.03

1Sensors running on SLES 12 support basic collection of processes and static machine information (such as interfaces), and do not support other collection actions.NOTE

Linux 32-bit operating systems are not supported.

NOTE

All Linux operating systems require Python 2.6+ or Python 3.x to be installed (the Cybereason platform supports all Python 3 versions, up to the latest Python version). For a full list of Linux installation requirements, see Linux installation requirements.

MOBILE DEVICES

All mobile devices (including phones and tablets) with a supported operating system are supported.

Operating system Support
Android 4
Android 5
Android 6
Android 7
Android 8
Android 9
Android 10
iOS 8
iOS 9
iOS 10
iOS 11
iOS 12
iOS 13
Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.

Still need help? Contact Us Contact Us